Previous Entry Share Next Entry
(Testers Wanted!) VDSL Mini-Challenge Ramdomizing Program
I'm a bit jealous of all the awesome VDSL challenges I've seen lately, but am occupied with one of my rare-but-really-awesome visits with boyfriend.  Compromise!  He made a spiffy little program so I can feel like I'm making progress on the challenge ;)

I introduce to you, the Mini-Challenge Chooser:

Could you do without this?  Absolutely.  But, I like clicking things, and I like sharing, and maybe you like clicking things, so you can randomize and check the challenge and then maybe randomize what sim it applies to with the Sim Selector, all in one place.  (In fact, you can use the Sim Selector to choose between sims for any related or unrelated reason you choose; I won't tell...)  If you format new challenges the same way, you can even import an entirely new set of challenges, such as for the Sims 3 Mini-Challenge list.  Edit: To save you a few steps I've just pasted the Sims 3 challenges in a txt here.  Go File > Open New File > and choose the txt.  To switch back to the default list, just close and reopen the program.

I think its pretty simple and self-explanatory, but there under help there is a glossary, credits, and input file formatting tips if you need it.  You can also post here if you have questions, and if you have trouble you can contact me or talon83636 .

-This program is a .jar and requires Java.
-EP requirements display at the bottom; this program does not ask or automatically detect and filter based on what you have installed.  It was gonna, but it would have been evil to do that and make future challenges importable.
-Tested in Windows 7 and Windows XP only so far. Edit: works in Windows Vista and on Macs, too.

  • 1
(Deleted comment)
It should work just by double-clicking it. If that doesn't work, I would suggest installing whatever the most recent version of Java there is. Let me know if you still have trouble executing it :)

Am I suppose to extract the file? Because when I double click the SimsChallenge.jar file a black box just quickly pops up and then runs words and goes away. I'm not quite sure what's suppose to happen. And I did extract it just for the hecks and I got a bunch of files relation to this program - but I'm not sure where the actual program is. I'm just now catching up with all my sims stuff so I'm not quite sure.

My guess would be you're using an old version of java. You can test what your current version is here. Java 6 Update 21 is the most recent version, which you can get here.

Honestly, it's not a very complicated program, so backward-compatibility shouldn't be too big of a problem, so I'm not completely sure if it's the problem, but it's late, so I can't think of what else it could be.

I am running the most recent version of Java so that's all settled. When I try to open the file this is what I get -

Well this is just confusing... It looks like a classpath problem, but seeing as how no one else has the problem I really don't see how that could be the case.

You could test it, if you want, but it might be overly complicated depending on a couple things:

Right click the .jar file and click "Extract to SimsChallenge\", then and navigate there in the command prompt ("cd C:\Users\Erica\Downloads\SimsChallenge"). Assuming there aren't any path problems, either "java Main" or "java -cp . Main" should work, so try them both. If the second works but the first doesn't it should give us a good idea of what the problem is.

To be perfectly honest, even if that is the problem, I'm not completely sure how to fix it. I'll keep working on it to try to find out what's wrong, though. I'm sorry for all the trouble. I'll try to get it working for you as soon as possible.

Hm.. I think I might have a clue to what the problem is. When I downloaded the file, at the time I didn't have Java so I downloaded the latest version (Java 6 Update 21). I rarely EVER used Java so I kinda did something stupid and clicked open the file with Java. It might be that because the file looks like this ( And whenever I double click the file - I think that's why it might be having that classpath problem.

So if you know how to change it back so the file opens with just it's regular state (just as a plain .jar file) that'd be great! :)

I've tried re-downloading the file, Re-installing Java, Right clicking the file and going to properties and trying to set a different open with. So if you know - It might be the solution. Because before when I didn't have Java and I tried opening the file it didn't work. This might help.

The icon you posted is what it's supposed to look like. The .jar file should run just fine by default as long as you have Java installed.

I have a few ideas about how to fix it, but I'm not completely sure which, if any of them will work for you particularly. If you'd rather do this through email or something it might be a bit faster.

(Deleted comment)
I figured out what the problem was and emailed you about it. (Actually emailed once, then realized what it was and emailed you again with the correct solution). The problem was, I'm assuming, that you set the .jar file to open with "java.exe". By default, .jar files are set to open with "javaw.exe". Changing it causes the error. Changing it back should fix everything.

  • 1

Log in

No account? Create an account